Mon, 07 Mar 2005

More messed up MTA with no communication.

I haven't had problems with mass transit in a week or two. So I was about due, right? Right.

Went to catch the Light Rail on my way home from work. Based on the timing, I figured I'd catch the 6:24 scheduled train from Timonium Fairgrounds. From a distance, I watched a train go through at 6:19. Based on the track signals and the fact that trains are almost never that early, I figured it was just really late and that another would be through shortly.

This turned out to be true; another one ran by a 6:34, presumably the 6:24 scheduled one. I was assisting a couple of out-of-town women with directions and they hadn't finished buying their tickets, so I said, "Oh, there should be another one in ten to twenty minutes." (Reasoning that the next scheduled train (6:44) probably wouldn't be more then ten minutes late itself. More the fool I.)

Over the next twenty minutes, three trains went by heading north. At 6:57, another one same by going south. It drove right through the station without stopping while sporting a sign that said "not in service". Another train went by heading north at 7:12. Finally, at 7:18, almost an hour since I'd gotten there and running 45 minutes behind the last train, another train finally came by to pick us up.

At no point was there any use made of the loudspeakers at the stop, nor does there appear to have been any announcement made via the MTA's website or mailing lists. The transit police officer at the station didn't know what was going on. (Though the delays didn't stop her from doing a fare check once the train was underway.)


Phil! Gold